English to Home Page Italiano
Home Cosa è INT3D Crea con INT3D Scene 3D Modellini 3D Strumenti Contatti
Nuovo applicativo dalla Pharus. Esempi.
Crea con INT3D    Inizia a creare
Pagina precedente Pagina successiva
Inizia a creare


Concetti base

INT3D-editor ha 10 principali pannelli di controllo.

Tutti i comandi in INT3D-Editor hanno istruzioni circa il loro uso: basta posizionare il cursore del mouse sopra ciascuno di essi e le informazioni appariranno sulla barra informativa (parte inferiore dello schermo).

INT3D-editor ha tre principali modalità (regimi) di utilizzo:
   1. "Build" - regime per la costruzione della scena attraverso il quale vengono impostati posizione e proprietà di ogni elemento. Questo regime si avvia automaticamente all'inizio del lavoro con INT3D-editor, ed è anche accessibile spingendo il tasto"Build" (Pannello I).
   2. "List" - regime per la scelta e visione preliminare degli elementi costruttivi e di arredo che si vogliono aggiungere nella propria scena. Questo regime si avvia tramite il tasto"List" (Pannello I) che fa accedere alla libreria dei modelli.
   3. "Tour" - regime per vedere interattivamente la scena e passeggiarci dentro. Vengono spenti tutti i panelli di controllo spingendo il tasto "Tour" (Pannello I) o "pagedown (tastiera). Un' ulteriore pressione su tali tasti permette di tornare indietro ai regimi "List" o "Build".

Regolazione delle dimensione dei pannelli sullo schermo:
Noi consigliamo di cominciare il lavoro con INT3D-editor impostando la scala di raffigurazione di tutti i pannelli di controllo sullo schermo; per farlo è necessario cliccare il tasto "Adjust" sul Pannello I e, trascinando il mouse sulla doppia freccia apparsa, scegliere la dimensione piu comoda dei pannelli. Cliccando nuovamente il tasto "Adjust" la doppia freccia scompare dallo schermo. A questo punto impostate la posizione più comoda per i pannelli di controllo cliccando e trascinando la striscia superiore blu come qualsiasi programma windows.

Se volete lavorare su una scena già esistente dovete attenderne il caricamento completo.

Camera / Background
Sul Pannello I, nella "lista di tutti gli elementi" presenti sulla scena, sulla prima riga trovate l'elemento "Camera" (telecamera). Può essere resa visibile sulla scena (cliccando un-Hide) , ma consigliamo di tenerla nascosta in regime "Build". Una volta selezionata sul pannello I, attraverso il tasto "Object" (Pannello III) è possibile:
   - Impostare l'ampiezza del campo visivo (in gradi) della telecamera nel regime "Tour" (il regime che permette di camminare all'interno della scena creata).
   - Modificare la scala dell'intera scena.
   - Impostare i colori dello sfondo.
   - Impostare il tipo di "navigazione" nel regime "Tour": 1-walk, 2-study, 3-fly or 0-none.
   - Impostare l'altezza dell'obbiettivo della telecamera rispetto al terreno quando si cammina nella scena in "Tour".

Cambiare questi parametri dovrebbe essere semplice ed intuitivo, tuttavia per una migliore spiegazione su come farlo vedete sotto "Come cambiare le proprietà di un oggetto".


Come selezionare un oggetto/elemento
Per cambiare la posizione, l'orientamento o le proprietà di un oggetto è necessario selezionarlo. Ci sono due modi per farlo:
   - Selezionare direttamente l'elemento sul Pannello I, cliccando sulla riga relativa.
   - In regime "Build", attivare la funzione "Find" (Pannello III) cliccando il relativo tasto e poi, sulla scena cliccare l'elemento desiderato.


Come modificare la posizione sulla scena di un elemento (selezionato)
E' possibile cambiare facilmente la posizione degli oggetti nella scena (p.e. spostare mobili secondo le proprie necessità). E' sufficiente selezionare l'elemento desiderato (vedi sopra) e con l'aiuto del Pannello III impostare una nuova posizione. Esistono vari modi:
   - cliccare sui tasti direzionali e di rotazione (posizionati sulla riga superiore del Pannello III) e trascinare il mouse.
   - attivare le funzioni "Touch&Set", "Normal" (Pannello III) e per posizionare l'oggetto selezionato basterà cliccare nel punto della scena desiderato. (molto utile p.es per posizionare velocemente gli infissi nelle bucature delle pareti). Attivando solo "Touch & set" l'oggetto viene posizionato mantenedo invariata la sua inclinazione rispetto ai 3 assi (X,Y,Z). Attivando contemporaneamente "Touch & set" e "Normal", l'oggetto cambia la sua inclinazione posizionandosi perpendicolarmente alla superficie cliccata.
   - attivare la funzione "Linear" Pannello III (che rende visibile gli assi x, y e z relativi all'elemento selezionato) e successivamente cliccare direttamente sull'asse/assi lungo il quale si vuole spostare l'oggetto trascinandolo con il mouse. Con lo stesso principio, attivando il tasto "Angular"è possibile ruotare l'oggetto secondo i tre assi. Gli assi e le circonferenze relative ad entrambe le funzioni possono essere visualizzati anche in regime "Tour" attraverso il tasto "in Tour", consentendo agli utenti di muovere oggetti direttamente in regime di visione della scena. Utilizzando queste funzioni, fate attenzione al comando "Snap" che consente di impostare valori numerici lineari ed angolari come aiuto per un più facile e preciso posizionamento.
   - per posizionare un oggetto in maniera molto precisa si può cliccare sul tasto "Object" (Pannello III) ed inserire sul Pannello VIII i valori numerici (fino al millimetro) relativi alle sue coordinate ed angoli di rotazione (attraverso il Pannello III o la tastiera).


Come rimuovere elementi dalla scena
Qualsiasi oggetto (a parte l'elemento "Camera") può essere rimosso dalla scena molto semplicemente, selezionandolo e cliccando il tasto "Del" sul Pannello I.

In alcuni casi può essere utile nascondere un elemento della scena; per farlo si usa il tasto "Hide" (Pannello I). Cliccando una seconda volta l'oggetto ritorna visibile.
Il tasto "All" fa riapparire tutti gli elementi precedentemente nascosti;
il tasto "None" fa scomparire tutti gli elementi;
il tasto "Inv" serve per visualizzare sulla scena uno o più elementi nascondendo tutti gli altri: si seleziona l'elemento/i desiderato/i e per ciascuno di essi si attiva la funzione "Hide" che li toglie momentaneamente dalla scena, spingendo il tasto "Inv" sulla scena appariranno solo gli elementi precedentemente nascosti.

Come aggiungere elementi nella scena
Per aggiungere un oggetto/elemento nuovo nella scena è neccessario andare sul regime "List" (Pannello I).
Dal catalogo dei modelli (Pannello IV) scegliere in consequenza:
   - elementi costruttivi (BASE) o elementi di arredo (FURNITURE);
   - il gruppo degli oggetti (Bases, Sofas, Tables ..);
   - modello (per esempio chair "Linda");
   - versione del modello ("a", "b", "c" ...).

Il modello selezionato apparirà sullo schermo e lo si potrà vedere da qualsiasi lato e posizione tramite i comandi del Pannello V. Per aggiungere il modello nella scena è sufficiente spingere il tasto "Add" (Panel V). Automaticamente apparirà sul Pannello I nella lista degli elementi. Ritornando nel regime "BUILD" sarà possibile impostare la posizione sulla scena dell'oggetto aggiunto.


Come copiare elementi nella scena
Per copiare oggetti all'interno della stessa scena è sufficiente selezionare l'oggetto/elemento da copiare e cliccare il tasto "Copy" sul Pannello I. L'oggetto/elemento copiato manterrà le stesse caratteristiche, parametri e proprietà dell'originale che se necessario potranno essere cambiate attraverso il tasto "Object" (Pannello III).


Come cambiare le proprietà di elemento
Per cambiare le proprietà dell'oggetto (dimensioni, scala, varianti..) bisogna selezionarlo e cliccare sul tasto "Object" (Pannello III in regime "Build") oppure sul tasto "Preset" (Pannello V in regime "List"). Apparirà un nuovo Pannello VII (proprietà dell'oggetto) attraverso il quale potranno essere impostati i nuovi parametri (tramite l'inserimento di valori numerici con il Pannello VI).


Come impostare materiali, tessiture e colori
Nella parte inferiore del Pannello VII (vedi paragrafo precedente) sono presenti i tasti "m1"-"m8"(i tasti dei materiali) - Cliccando su ognuno di essi si aprirà un ulteriore Pannello X "editor dei materiali e delle tessiture" attraverso le funzioni del quale è possibile impostare o cambiare non solo le tessiture, ma anche il loro angolo di rotazione, la scala, il colore, la brillantezza, la lucidità ecc ... .

IMPOSTAZIONE DEI COLORI:
INT3D-Editor utilizza i due più importanti e famosi sistemi di impostazione dei colori: RGB and HSV (per passare da un sistema all'altro è sufficiente cliccare sui tasti "RGB/HSV" (Pannello X) che consentono di ottenere un'infinita varietà di colori ed effetti. Cliccando sul tasto "None" in cima al pannello, all'oggetto selezionato non viene applicata nessuna tessitura, ma viene applicato il colore, le cui caratteristiche (tipo, tonalità, sfumature ecc. ) sono impostati cliccando sul tasto "Textures/Materials" ed agendo sui parametri RGB /HSV attraverso le funzioni : "diffus colours", "specular colours", "emissive colours", "ambient intensity", "shininess", "trasparency" con le quali è possibile tra l'altro ottenere effetti quali : metallo, plastica, vetro ... .
Alla sinistra del tasto "Trasparency" vi è una freccia. Cliccando e trascinando con il mouse è possibile allargare il pannello dei parametri permettendo una più ampia e precisa possibiltà di scelta.

IMPOSTAZIONE DELLE TESSITURE:
Sul pannello sono presenti 260 tessiture che verranno continuamente integrate ed aggiornate nel tempo, suddivise in 16 categorie (legno, parquette, pavimenti, intonaci, pietre, marmi, pelle, tessuti, mattoni, piastrelle, flora,...). E' sufficiente cliccare sulla tessitura desiderata ed essa viene automaticamente applicata all'oggetto (o ad una parte dell'oggetto) selezionato. Le funzioni "Rot" e "Scl" permetteno di impostare l'angolo di rotazione e la scala della tessitura, mentre il cerchietto nero posizionato tra i due comandi (Rot e Scl) è utile quando si abbia la necessità di adattare le tessiture di elementi combacianti. Una volta scelta la tessitura, cliccando sul tasto "Material/Texture" si possono impostare effetti e caratteristiche quali:
   - tonalità: agendo sui tre parametri RGB o HSV attraverso la funzione "emissive colours";
   - capacità: di riflessione fonti di luce : attraverso la funzione "specular colours"
   - luminosità: attraverso la funzione "ambient intensity"
   - brillantezza: attraverso la funzione "shininess"
   - lucidità: attraverso il parametro "V" di HSV in "specular colour";
   - trasparenza: attraverso la funzione "trasparency".

Noi consigliamo di famigliarizzare con le varie funzioni di questo editor effettuando prove e componendo tra loro i diversi parametri a disposizione, perchè le possibilità sono veramente infinite.
Raccomandiamo di usare anche i comandi "Copy" e "Paste". Molto utili perche permettono di copiare il tipo di colore o tessitura (ed i relativi parametri) da un elemento selezionato ed applicarlo ad altri elementi.
Spingendo il tasto "OK" in basso a destra, il pannello dei Materiali e Tessiture viene chiuso.


Come salvare la scena creata
Il salvataggio della scena è possibile in qualsiasi fase, anche dopo essersi disconnessi da Internet.
Questa funzione non è complicata ma richiede attenzione ed accuratezza.
Per salvare la scena è necessario spingere il tasto "Save" (Pannello I)vi si presenteranno tre possibilità:
   - "Save to internal-format (for future editing)": questa opzione permette di modificare in futuro la scena salvata. Attualmente la modifica è possibile solo online collegandosi ad INT3D-Editor.
   - "Save to external-format (for publishing)": questa opzione permette di salvare la scena in un formato che ne consente la sola visione. Va usata quando si ritiene di avere completato la scena e la si voglia salvare sul proprio computer per una successiva visione o pubblicazione sul web. Il caricamento della scena sarà molto più veloce, ma la scena salvata in questa modalità non potra più essere modifcata. Installando sul proprio computer la "libbreria dei modelli e tessiture INT3D" che si scarica gratuitamente dal nostro sito, la visione delle scene salvate in questa modalità sarà posssibile anche sensa connessione a Internet.
   - "Save as external block for another scene": In questo caso la scena viene salvata come un unico blocco, allo scopo di importarla all'interno di altre scene (vedi "come importare oggetti dall'URL"). Molto utile per crearsi una libbreria pesonale di blocchi (elementi ottenuti componendo altri elementi) da inserire in seguito in una qualsiasi scena.

In tutte e tre le opzioni INT3D-editor eseguirà una preparazione al salvataggio che può richiedere alcuni minuti in base alla quantità degli oggetti nella scena. Il risultato sarà l'apertura di una nuova finestra con la versione testuale della vostra INT3D-scena ed il suggerimento in inglese sulla procedura di salvataggio).
L'operazione si effettua nei diversi Internet-browsers in maniera diversa:

Per il corretto salvataggio della scena con Internet Explorer:

1. Scegliere "Visualizza" -> "HTML" -> Notepade;
2. In Notepad - "File" -> "Salva con nome..";
3. Il nome per il salvataggio deve avere questa struttura : qualsiasi.wrl (per esempio grande.wrl).

Per il corretto salvataggio della scena con Netscape Navigator:

1. Scegliere -"File" -> "Salva con nome..";
2. Il nome per il salvataggio deve avere questa struttura : qualsiasi.wrl (per esempio grande.wrl).

Se avete problemi provate con il seguente metodo:

Selezionate (Ctrl-A) e copiate (Ctrl-C) tutto il testo della pagina;
Aprite Notepad ed incollate (Ctrl-V) il testo copiato;
In Notepad - "File" -> "Salva con nome..";
Il nome per il salvataggio deve avere questa struttura: qualsiasi.wrl.

Per caricare la scena salvata semplicemente aprite questo file.
[Home] [Cosa è INT3D] [Crea con INT3D] [Scene 3D] [Modellini 3D] [Strumenti] [Contatti]
Copyright© 2001-2006 Pharus di Giovanni Dragone